viernes, 31 de octubre de 2008

windows, ruby on rails, sqlite3



Download Ruby from:
http://www.ruby-lang.org/es/downloads/

binarios compilados
ftp://ftp.ruby-lang.org/pub/ruby/binaries/mswin32/ruby-1.8.6-i386-mswin32.zip

UnZip:
C:\ruby

PATH=%PATH%;C:\ruby\bin

Download RubyGems from:
http://rubygems.rubyforge.org

http://rubyforge.org/frs/download.php/45906/rubygems-1.3.1.zip

UnZip:
C:\rubygems-1.3.1

C:\rubygems-1.3.1>ruby setup.rb

C:\gem install rails --include-dependencies

Problemas No Encuentra Esto:
zlib.dll
SSLEAY32.dll

A otra cosa,

Eliminar
C:\ruby

Eliminar
C:\rubygems-1.3.1



Ahora con One-Click Installer:

http://rubyforge.org/frs/download.php/18566/ruby186-25.exe

C:>gem install rails --include-dependencies




C:>mkdir src
C:>cd src
C:\src>mkdir work
C:\src>cd work
C:\src\work>rails demo
C:\src\work>cd demo
C:\src\work\demo>ruby script\server

Rails requires RubyGems >= 1.1.1 (you have 0.9.2). Please `gem update --system`
and try again.

C:\src\work\demo>gem update --system

C:\src\work\demo>ruby script\server

http://localhost:3000/



no such file to load -- sqlite3

http://www.sqlite.org/download.html

UnZip and Copy:
C:\ruby\bin\sqlite3.exe

C:\>gem install sqlite3-ruby
checking for fdatasync() in rt.lib... no


from http://groups.google.com/group/comp.lang.ruby/browse_thread/thread/9d5c9ee6167dace4
http://www.sqlite.org/download.html

UnZip and Copy:
C:\ruby\bin\sqlite3.dll
C:\ruby\bin\sqlite3.def

C:\>gem install sqlite3-ruby
checking for fdatasync() in rt.lib... no

from http://www.nabble.com/Beginner-help:-Problem-installing-sqlite3-on-Windows-XP-td19200418.html
Jim Carter

C:\>gem install --version 1.2.3 sqlite3-ruby

http://localhost:3000/rails/info/properties
Perfecto!!!

No hay comentarios.: